[Trisquel-users] Problems with DTLAPC14

mason at masonhock.com mason at masonhock.com
Wed Feb 27 08:28:46 CET 2019


Don't mess around with JACK when you don't yet have ALSA working. Like  
Pulseaudio, JACK is a sound server that controls and relies on ALSA.  
Pulseaudio is intended to work out-of-the box for basic desktop usage. JACK  
is more advanced (i.e. for professional audio production) and requires more  
configuration. I know a lot of musicians, so I frequently set up JACK on  
people's laptops, and every new sound card I encounter is a unique  
pain-in-the-adventure. Installing JACK has the potential to break sound if it  
was already working, but if ALSA already wasn't working then JACK won't make  
things any better. If you're a musician, I'll help you through installing and  
configuring JACK *after* we get ALSA working. Otherwise you're better off  
with ALSA+Pulseaudio or (if you don't use GNOME or a Firefox-based browser)  
just ALSA.

I've seen many cases where these things worked with just ALSA but not with  
JACK+ALSA. Pulseaudio+ALSA has worked on the dozen or so laptops on which  
I've install Trisquel 8, but I have heard of people having problems with it.  
For now lets keep it simple and just get ALSA working.

Purge ALSA, Pulseaudio, and JACK. Reinstall *just* ALSA. Run "alsamixer" and  
try all of the available devices. Don't test audio through Abrowser, because  
Firefox-derivatives no longer work without Pulseaudio. Instead play an audio  
or video file through your preferred media player.


More information about the Trisquel-users mailing list