[Trisquel-users] Trisquel continuously crashing, the state of the FOSS community

Caleb Herbert csh at bluehome.net
Sun Feb 24 23:59:13 CET 2019


ethancrist96 at gmail.com wrote ..
> I have had much trouble with this OS. 

I have not. It's just as bad as Debian Stable, no worse, and a little
better.

> Both on my desktop and on a laptop, the 
> OS will crash anywhere from 0-10 minutes after startup every time
without  
> incident.

I have had Trisquel on several computers. They've all worked just as
good as any other OS, even with Wi-Fi.

- Asus laptop
- System76 Meerkat
- ThinkPad X60s
- ThinkPad X200

> I doubt this is an installation issue as the Technoethical laptop  

I have no experience with Technoethical and don't need any. Minifree
has always served me well, providing me with very clean and functional
hardware and surpassing my expectations.

>  I have no  
> idea what kind of programmer fancied this project is even close to
being  
> viable for production when it appears this unstable. There is no way
in hell  
> mainstream adoption is possible with these kind of gaping bugs.

It's Ubuntu LTS. It powers many important services around the world.
The FSF uses it internally for all their operations. LibrePlanet was
streamed with Trisquel 8 before it was even released. The server that
powers my email runs Trisquel 8 and rarely ever has issues.

> The sloppiness of this software, combined with the lack of awareness
and  
> concern of these bugs in the free software movement will be its
downfall. I  
> am a programmer myself and this apathy deeply worries me. I'm happy to  
> provide help to make this software more accessible and usable if
someone can  
> help point me in the right direction. 

https://devel.trisquel.info/

Get to work.

> Let's start with whatever bug is  
> causing the fatal crash on my machine.

My Minifree machine Just Works™️. I'm buying a new one soon, in fact.

> Attached is a good portion of my syslog. There were probably at
least a dozen 
> crashes within this log.

Have you tried booting plain Ubuntu 16.04 LTS on it? If I think there
might be an issue with upstream, I test it with upstream and report
the issue there. 


More information about the Trisquel-users mailing list