[Trisquel-users] Icecat seems very outdated, what browser *should* one be using?

jason at bluehome.net jason at bluehome.net
Sun Feb 10 04:56:58 CET 2019


Similar to Debian stable, general policy is to freeze package versions on the  
release of a given Trisquel version and then apply only security patches/bug  
fixes. But the version number remains frozen. I personally like this policy.


More information about the Trisquel-users mailing list