[Trisquel-users] Icecat seems very outdated, what browser *should* one be using?

lovexdrew at gmail.com lovexdrew at gmail.com
Sun Feb 10 00:44:46 CET 2019


I've installed Trisquel Mini and I love it. I love Trisquel mini. It's so  
much faster than Trisquel on my Libreboot X60.

The browser it comes with is Midori, a browser I fell in love with when it  
came around but the project died like 4 years ago and AFAIK it still uses a  
build of webkit that has a bunch of secuirty issues, which will never be  
fixed since the project is dead.

I did [ sudo apt-get install icecat] to use the browser that normally comes  
with Trisquel and I've found that it and some of it's addons are outdated. As  
of yesterday installing Icecat means you can't visit *any* websites using  
HTTPS, you will always get a 'content encoding error' which can only be fixed  
by disableing all addons. I'm not sure which one is doing it, I can only tell  
that it's not spyblock or httpseverywhere.


I tried to use the links icecat provides to install AdblockEdge and got a  
404.

I tried to install Ublock Origin from the mozilla website. I can't install  
it, it gives me this: This add-on requires a newer version of Firefox (at  
least version 55.0). You are using Firefox 52.0.



I tried to use github and my schools website for homework, github renders a  
little weird, my school website is entirely broken. Both give errors saying  
my browser is outdated.




So, what *should* I be using? What are you all using with Trisquel?


More information about the Trisquel-users mailing list