[Trisquel-users] Installing Trisquel 7 on HP DV 5000 (many issues?)

chris at thinkpenguin.com chris at thinkpenguin.com
Sun Aug 31 00:28:46 CEST 2014


Please note that this is largely off the top of my head and I didn't test  
this thoroughly...

That said to install do the following:

1. During boot hold down the left shift key to get the GRUB boot menu to show

2. Press the 'e' key to edit the boot parameters. Using the cursor keys of  
your keyboard scroll down to the line that starts with "linux" and go to the  
end of that line.

3. Add the boot parameters "nomodeset xforcevesa" without the quotes. As you  
type, it will wrap to the next line on the screen and show a backslash  
character at the end of the previous line. That's fine. Press Ctrl+X or F10  
to continue to boot.

After installing it the system won't boot, but you can use a live cd with  
chroot to fix this. Use the above directions to boot from the Trisquel live  
cd again.

Then from the live CD open a terminal and run:

sudo mkdir -p /mnt/chroot

Then mount the partition you installed Trisquel to:

sudo mount  /dev/sda1 /mnt/chroot

Next we need to bind hardware with new chroot environment. The next commands  
will make sure that connected hardware works otherwise update-grub may not  
function properly.

Run:

sudo mount -o bind /proc /mnt/chroot/proc
sudo mount -o bind /proc /mnt/chroot/dev

Now enter the chroot environment:

sudo chroot /mnt/chroot


Assuming your not booting in UEFI mode you can put "nomodeset xforcevesa"  
into /etc/default/grub. To open the file for editing, run:

gksudo gedit /etc/default/grub

locate the following line and put xforcevesa between the quotes:

GRUB_CMDLINE_LINUX_DEFAULT="nomodeset xforcevesa"

save and exit when done, then run the following for the change to take  
effect:

sudo update-grub


If everything worked right you should be able to reboot now and the system  
will boot without the 3d aceelerated graphics driver. In theory that is  
probably what is causing the problem between the two releases.

If anybody else has another idea as to what might be causing the problem  
speak up!



More information about the Trisquel-users mailing list