[Trisquel-users] Problems Installing Abrowser/Icecat

Perseo icaro.perseo at gmail.com
Sat Aug 30 05:18:38 CEST 2014


El sáb, 30-08-2014 a las 03:06 +0200, a1716479 at trbvm.com escribió:
> 	Ok, so.  Icecat is successfully installed!  Thank you everyone who helped.   
> I truly haven’t encountered such a helpful Linux community before, not to  
> diss anyone, but you guys have been much more helpful.
> 	Following your advice I:
> ~$ sudo apt-get install xul-ext-torproxy tor
> [sudo] password for localhost5:
> Reading package lists... Done
> Building dependency tree
> Reading state information... Done
> Package xul-ext-torproxy is not available, but is referred to by another  
> package.
> This may mean that the package is missing, has been obsoleted, or
> is only available from another source
> 
> E: Package 'xul-ext-torproxy' has no installation candidate
> 
> Ok so I downloaded it like Legimet said, and:
> 
> ~$ sudo dpkg -i  
> /home/localhost5/Downloads/Icecat-31.0/xul-ext-torproxy_2.3_all.deb
> Selecting previously unselected package xul-ext-torproxy.
> (Reading database ... 242178 files and directories currently installed.)
> Unpacking xul-ext-torproxy (from .../xul-ext-torproxy_2.3_all.deb) ...
> dpkg: dependency problems prevent configuration of xul-ext-torproxy:
>   xul-ext-torproxy depends on tor; however:
>    Package tor is not installed.
> dpkg: error processing xul-ext-torproxy (--install):
>   dependency problems - leaving unconfigured
> Errors were encountered while processing:
>   xul-ext-torproxy
> 
> Ok, so...
> 
> sudo synaptic
> 
> “You have one broken package.  Please...blablabla”
> 
> So I fixed that, then used synaptic to install it, and that worked.
> 
> I then downloaded, and tried installing the Icecat packages with sudo dpkg -i  
> (starting with icecat_31.0+gnu3_amd64.deb) again.
> 
> (Reading database ... 243492 files and directories currently installed.)
> Preparing to replace icecat 31.0+gnu3 (using .../icecat_31.0+gnu3_amd64.deb)  
> ...
> Unpacking replacement icecat ...
> dpkg: dependency problems prevent configuration of icecat:
>   icecat depends on libc6 (>= 2.17); however:
>    Version of libc6 on system is 2.15-0ubuntu10.7.
>   icecat depends on libfontconfig1 (>= 2.9.0); however:
>    Version of libfontconfig1 on system is 2.8.0-3ubuntu9.1.
>   icecat depends on libglib2.0-0 (>= 2.37.3); however:
>    Version of libglib2.0-0 on system is 2.32.4-0ubuntu1.
>   icecat depends on libpango-1.0-0 (>= 1.22.0); however:
>    Package libpango-1.0-0 is not installed.
>   icecat depends on libpangocairo-1.0-0 (>= 1.14.0); however:
>    Package libpangocairo-1.0-0 is not installed.
> dpkg: error processing icecat (--install):
>   dependency problems - leaving unconfigured
> Processing triggers for desktop-file-utils ...
> Processing triggers for man-db ...
> Errors were encountered while processing:
>   icecat
> 
> eh...
> 
> 	Then software center opened, (this sometimes happens when I install debs)  
> and displayed the message below.  So I let it run it’s fix, then looked for  
> Icecat in software center, and found it, so I ran the install.  Well that did  
> it.  “shrugs”
> 	Anyway I couldn’t have done it without your help.  Thank you so much.

you are welcome :).



More information about the Trisquel-users mailing list