[Trisquel-users] Laser Printer compatible with Trisquel or totally free distributions ?

chris at thinkpenguin.com chris at thinkpenguin.com
Thu Aug 21 01:49:18 CEST 2014


I've had some bad experiences with Samsung printers. It was with one of the  
early low end laser printers in fact. It's the same with HP I believe. In any  
event despite Samsung clearly advertising support for "Linux", they only  
provided proprietary drivers for a few distributions. I believe it was Redhat  
and maybe SUSE. These low end laser printers aren't a good choice for  
GNU/Linux users. They're generally not postscript compliant, and dependent on  
some non-free driver.

That said if you bought a higher end laser printer years ago there is a much  
better chance it'll work fairly seamlessly as most of the higher end laser  
printers traditionally have been postscript compliant making supporting them  
easy. It is less true today than ever before though. However that said I  
believe there are still a lot of higher end laser printers with postscript  
support on the market.


More information about the Trisquel-users mailing list