[Trisquel-users] Lantern - An app to end censorship

adrian.malacoda at member.fsf.org adrian.malacoda at member.fsf.org
Thu Aug 14 16:43:59 CEST 2014


A number of red flags popped out to me, aside from the dependency on Google  
services (which they claim they will remove soon[1])

Readme[2] claims that it requires Oracle JDK specifically, and OpenJDK will  
not work. As is typical, they don't explain why this is the case. Now, I know  
Java people want everyone to use Oracle JDK as a matter of habit, so maybe it  
will work with OpenJDK and they just never bothered to test it.

Readme also states that the installer is built with proprietary tools. This  
isn't a problem if you build it from source. It may or may not depend on  
Chrome (apparently they removed this in a later version) or it may or may not  
bundle a Chromium based UI (which is not apparent).

The project also specifically targets Ubuntu "Linux" instead of GNU/Linux in  
general, which shouldn't cause problems but is a red flag for me in general.

[1] https://github.com/getlantern/lantern/issues/1717
[2] https://github.com/getlantern/lantern


More information about the Trisquel-users mailing list